What’s Vulnerable › Vulnerabilities
CVE-2023-0668: Wireshark IEEE-C37.118 parsing buffer overflow
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-125
Description
Due to failure in validating the length provided by an attacker-crafted IEEE-C37.118 packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.
Affected products
- Debian Linux: 12.0
- Wireshark Foundation Wireshark: from 3.6.0 before 3.6.14; from 4.0.0 before 4.0.6 — fixed in 3.6.14, 4.0.6
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 3.6.14, 4.0.6. Check the vendor advisory for mitigations.
References
- https://gitlab.com/wireshark/wireshark/-/issues/19087
- https://security.gentoo.org/glsa/202309-02
- https://takeonme.org/cves/CVE-2023-0668.html
- https://www.debian.org/security/2023/dsa-5429
- https://www.wireshark.org/docs/relnotes/wireshark-4.0.6.html
- https://www.wireshark.org/security/wnpa-sec-2023-19.html
- https://gitlab.com/wireshark/wireshark/-/issues/19087
- https://lists.debian.org/debian-lts-announce/2024/09/msg00049.html
- https://security.gentoo.org/glsa/202309-02
- https://takeonme.org/cves/CVE-2023-0668.html
- https://www.debian.org/security/2023/dsa-5429
- https://www.wireshark.org/docs/relnotes/wireshark-4.0.6.html
Get alerted when CVE-2023-0668 or the next vulnerability affects your stack