What’s Vulnerable › Vulnerabilities
CVE-2023-0714: Metform Elementor Contact Form Builder <= 3.2.4 - Unauthenticated Double-Extension Arbitrary File Upload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-17 · updated 2026-06-17
- Weakness: CWE-434
Description
The Metform Elementor Contact Form Builder for WordPress is vulnerable to Arbitrary File Upload due to insufficient file type validation in versions up to, and including, 3.2.4. This allows unauthenticated visitors to perform a "double extension" attack and upload files containing a malicious extension but ending with a benign extension, which may make remote code execution possible in some configurations.
Affected products
- roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor: before 3.3.0 — fixed in 3.3.0
How to fix
Upgrade to a fixed version: roxnor MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor 3.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/metform/trunk/core/entries/file-data-validation.php?rev=2746287
- https://plugins.trac.wordpress.org/changeset/2896914/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/697ce433-f321-4977-a2ad-68369d9ce9c3?source=cve
Get alerted when CVE-2023-0714 or the next vulnerability affects your stack