What’s Vulnerable › Vulnerabilities
CVE-2023-0731: Interactive Geo Maps <= 1.5.9 - Authenticated (Editor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Interactive Geo Maps plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the action content parameter in versions up to, and including, 1.5.9 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with editor level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- interactivegeomaps MapGeo – Interactive Geo Maps: before 1.5.11 — fixed in 1.5.11
How to fix
Upgrade to a fixed version: interactivegeomaps MapGeo – Interactive Geo Maps 1.5.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2861473%40interactive-geo-maps%2Ftrunk&old=2857078%40interactive-geo-maps%2Ftrunk&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/95ce515a-377c-49b4-8d1b-7ac22769c759?source=cve
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2861473%40interactive-geo-maps%2Ftrunk&old=2857078%40interactive-geo-maps%2Ftrunk&sfp_email=&sfph_mail=#file4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/95ce515a-377c-49b4-8d1b-7ac22769c759
Get alerted when CVE-2023-0731 or the next vulnerability affects your stack