What’s Vulnerable › Vulnerabilities

CVE-2023-0756

Description

An issue has been discovered in GitLab affecting all versions before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. The main branch of a repository with a specially crafted name allows an attacker to create repositories with malicious code, victims who clone or download these repositories will execute arbitrary code on their systems.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.5, 15.11.1, 15.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-0756 or the next vulnerability affects your stack