What’s Vulnerable › Vulnerabilities
CVE-2023-0767
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-02 · updated 2026-10-24
Description
An attacker could construct a PKCS 12 cert bundle in such a way that could allow for arbitrary memory writes via PKCS 12 Safe Bag attributes being mishandled. This vulnerability affects Firefox < 110, Thunderbird < 102.8, and Firefox ESR < 102.8.
Affected products
- Mozilla Firefox: before 110.0 — fixed in 110.0
- Mozilla Firefox ESR: before 102.8 — fixed in 102.8
- Mozilla Thunderbird: before 102.8 — fixed in 102.8
How to fix
Upgrade to a fixed version: Mozilla Firefox 110.0; Mozilla Firefox ESR 102.8; Mozilla Thunderbird 102.8. Check the vendor advisory for mitigations.
References
- https://alas.aws.amazon.com/AL2/ALAS-2023-1992.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1804640
- https://www.mozilla.org/security/advisories/mfsa2023-05/
- https://www.mozilla.org/security/advisories/mfsa2023-06/
- https://www.mozilla.org/security/advisories/mfsa2023-07/
- https://alas.aws.amazon.com/AL2/ALAS-2023-1992.html
- https://bugzilla.mozilla.org/show_bug.cgi?id=1804640
- https://security.netapp.com/advisory/ntap-20230324-0008/
- https://www.mozilla.org/security/advisories/mfsa2023-05/
- https://www.mozilla.org/security/advisories/mfsa2023-06/
- https://www.mozilla.org/security/advisories/mfsa2023-07/
Get alerted when CVE-2023-0767 or the next vulnerability affects your stack