What’s Vulnerable › Vulnerabilities
CVE-2023-0780: Improper Restriction of Rendered UI Layers or Frames in cockpit-hq/cockpit
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-11 · updated 2026-06-17
- Weakness: CWE-1021
Description
Improper Restriction of Rendered UI Layers or Frames in GitHub repository cockpit-hq/cockpit prior to 2.3.9-dev.
Affected products
- cockpit-hq/cockpit: before 2.3.9 — fixed in 2.3.9
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.3.9. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/8450bdf7e1dc23e9d88adf30a2aa9101c0c41720
- https://huntr.dev/bounties/801efd0b-404b-4670-961a-12a986252fa4
- https://github.com/cockpit-hq/cockpit/commit/8450bdf7e1dc23e9d88adf30a2aa9101c0c41720
- https://huntr.dev/bounties/801efd0b-404b-4670-961a-12a986252fa4
Get alerted when CVE-2023-0780 or the next vulnerability affects your stack