What’s Vulnerable › Vulnerabilities
CVE-2023-0810: Cross-site Scripting (XSS) - Stored in btcpayserver/btcpayserver
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository btcpayserver/btcpayserver prior to 1.7.11.
Affected products
- Btcpayserver: before 1.7.11 — fixed in 1.7.11
How to fix
Upgrade to a fixed version: Btcpayserver 1.7.11. Check the vendor advisory for mitigations.
References
- https://github.com/btcpayserver/btcpayserver/commit/dffa6accb04df7b80bc584dedef22c9297292ce6
- https://huntr.dev/bounties/a48414ea-63d9-453c-b3f3-2c927b71ec68
- https://github.com/btcpayserver/btcpayserver/commit/dffa6accb04df7b80bc584dedef22c9297292ce6
- https://huntr.dev/bounties/a48414ea-63d9-453c-b3f3-2c927b71ec68
Get alerted when CVE-2023-0810 or the next vulnerability affects your stack