What’s Vulnerable › Vulnerabilities
CVE-2023-0821: Nomad Client Vulnerable to Decompression Bombs in Artifact Block
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-409
Description
HashiCorp Nomad and Nomad Enterprise 1.2.15 up to 1.3.8, and 1.4.3 jobs using a maliciously compressed artifact stanza source can cause excessive disk usage. Fixed in 1.2.16, 1.3.9, and 1.4.4.
Affected products
- HashiCorp Nomad Enterprise: before 1.2.15; from 1.3.0 before 1.3.9; from 1.4.0 before 1.4.4 — fixed in 1.2.15, 1.3.9, 1.4.4
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.2.15, 1.3.9, 1.4.4. Check the vendor advisory for mitigations.
References
- https://discuss.hashicorp.com/t/hcsec-2023-05-nomad-client-vulnerable-to-decompression-bombs-in-artifact-block/50292
- https://discuss.hashicorp.com/t/hcsec-2023-05-nomad-client-vulnerable-to-decompression-bombs-in-artifact-block/50292
Get alerted when CVE-2023-0821 or the next vulnerability affects your stack