What’s Vulnerable › Vulnerabilities
CVE-2023-0836
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-200
Description
An information leak vulnerability was discovered in HAProxy 2.1, 2.2 before 2.2.27, 2.3, 2.4 before 2.4.21, 2.5 before 2.5.11, 2.6 before 2.6.8, 2.7 before 2.7.1. There are 5 bytes left uninitialized in the connection buffer when encoding the FCGI_BEGIN_REQUEST record. Sensitive data may be disclosed to configured FastCGI backends in an unexpected way.
Affected products
- HAProxy: from 2.2.0 before 2.2.27; from 2.4.0 through 2.4.21; from 2.5.0 through 2.5.11; from 2.6.0 through 2.6.8; 2.1.0, 2.3.0, 2.7.0 — fixed in 2.2.27
How to fix
Upgrade to a fixed version: HAProxy 2.2.27. Check the vendor advisory for mitigations.
References
- https://git.haproxy.org/?p=haproxy.git%3Ba=commitdiff%3Bh=2e6bf0a
- https://www.debian.org/security/2023/dsa-5388
- https://git.haproxy.org/?p=haproxy.git%3Ba=commitdiff%3Bh=2e6bf0a
- https://www.debian.org/security/2023/dsa-5388
Get alerted when CVE-2023-0836 or the next vulnerability affects your stack