What’s Vulnerable › Vulnerabilities
CVE-2023-0861: Authenticated Command Injection in NetModule NSRW
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
- Weakness: CWE-77
Description
NetModule NSRW web administration interface executes an OS command constructed with unsanitized user input. A successful exploit could allow an authenticated user to execute arbitrary commands with elevated privileges. This issue affects NSRW: from 4.3.0.0 before 4.3.0.119, from 4.4.0.0 before 4.4.0.118, from 4.6.0.0 before 4.6.0.105, from 4.7.0.0 before 4.7.0.103.
Affected products
- Netmodule Router Software: from 4.3.0.0 before 4.3.0.119; from 4.4.0.0 before 4.4.0.118; from 4.6.0.0 before 4.6.0.105; from 4.7.0.0 before 4.7.0.103 — fixed in 4.3.0.119, 4.4.0.118, 4.6.0.105, 4.7.0.103
How to fix
Upgrade to a fixed version: Netmodule Router Software 4.3.0.119, 4.4.0.118, 4.6.0.105, 4.7.0.103. Check the vendor advisory for mitigations.
References
- https://onekey.com/blog/security-advisory-netmodule-multiple-vulnerabilities
- https://share.netmodule.com/public/system-software/4.7/4.7.0.103/NRSW-RN-4.7.0.103.pdf
- https://onekey.com/blog/security-advisory-netmodule-multiple-vulnerabilities
- https://share.netmodule.com/public/system-software/4.7/4.7.0.103/NRSW-RN-4.7.0.103.pdf
Get alerted when CVE-2023-0861 or the next vulnerability affects your stack