What’s Vulnerable › Vulnerabilities
CVE-2023-0867: Multiple stored and reflected Cross-site Scripting in webapp
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected products
- The OpenNMS Group Horizon: before 31.0.4 — fixed in 31.0.4
- The OpenNMS Group Meridian: before 2023.1.0 — fixed in 2023.1.0
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 31.0.4; The OpenNMS Group Meridian 2023.1.0. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/meridian/2022/releasenotes/changelog.html#releasenotes-changelog-Meridian-2022.1.13
- https://github.com/OpenNMS/opennms/pull/5765
- https://docs.opennms.com/meridian/2022/releasenotes/changelog.html#releasenotes-changelog-Meridian-2022.1.13
- https://github.com/OpenNMS/opennms/pull/5765
Get alerted when CVE-2023-0867 or the next vulnerability affects your stack