What’s Vulnerable › Vulnerabilities
CVE-2023-0869: Cross-site scripting in outage/list.htm
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-23 · updated 2026-06-17
- Weakness: CWE-20
Description
Cross-site scripting in outage/list.htm in multiple versions of OpenNMS Meridian and Horizon allows an attacker access to confidential session information. The solution is to upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected products
- The OpenNMS Group Horizon: before 31.0.4 — fixed in 31.0.4
- The OpenNMS Group Meridian: before 2023.1.0 — fixed in 2023.1.0
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 31.0.4; The OpenNMS Group Meridian 2023.1.0. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.0
- https://github.com/OpenNMS/opennms/pull/5734
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.0
- https://github.com/OpenNMS/opennms/pull/5734
Get alerted when CVE-2023-0869 or the next vulnerability affects your stack