What’s Vulnerable › Vulnerabilities
CVE-2023-0870: Form Can Be Manipulated with Cross-Site Request Forgery (CSRF)
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-22 · updated 2026-06-17
- Weakness: CWE-352
Description
A form can be manipulated with cross-site request forgery in multiple versions of OpenNMS Meridian and Horizon. This can potentially allow an attacker to gain access to confidential information and compromise integrity. The solution is to upgrade to Meridian 2023.1.1 or Horizon 31.0.6 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Affected products
- The OpenNMS Group Horizon: before 31.0.6 — fixed in 31.0.6
- The OpenNMS Group Meridian: from 2020.1.0 before 2020.1.33; from 2021.1.0 before 2021.1.25; from 2022.1.0 before 2022.1.14; 2023.1.0 — fixed in 2020.1.33, 2021.1.25, 2022.1.14
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 31.0.6; The OpenNMS Group Meridian 2020.1.33, 2021.1.25, 2022.1.14. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.1
- https://github.com/OpenNMS/opennms/pull/5835/files
- https://docs.opennms.com/meridian/2023/releasenotes/changelog.html#releasenotes-changelog-Meridian-2023.1.1
- https://github.com/OpenNMS/opennms/pull/5835/files
Get alerted when CVE-2023-0870 or the next vulnerability affects your stack