What’s Vulnerable › Vulnerabilities
CVE-2023-0872: ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-14 · updated 2026-06-17
- Weakness: CWE-269
Description
The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.
Affected products
- The OpenNMS Group Horizon: from 31.0.8 before 32.0.2 — fixed in 32.0.2
- The OpenNMS Group Meridian: from 2020.0.0 through 2020.1.37; from 2021.0.0 through 2021.1.29; from 2022.0.0 through 2022.1.18; from 2023.0.0 through 2023.1.5
How to fix
Upgrade to a fixed version: The OpenNMS Group Horizon 32.0.2. Check the vendor advisory for mitigations.
References
- https://docs.opennms.com/horizon/32/releasenotes/changelog.html
- https://github.com/OpenNMS/opennms/pull/6354
- https://docs.opennms.com/horizon/32/releasenotes/changelog.html
- https://github.com/OpenNMS/opennms/pull/6354
Get alerted when CVE-2023-0872 or the next vulnerability affects your stack