What’s Vulnerable › Vulnerabilities
CVE-2023-0874: Klaviyo <= 3.0.10 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
Description
The Klaviyo WordPress plugin before 3.0.10 does not sanitize and escape some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Klaviyo Klavio: before 3.0.10 — fixed in 3.0.10
How to fix
Upgrade to a fixed version: Klaviyo Klavio 3.0.10. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/495e39db-793d-454b-9ef1-dd91cae2c49b
- https://wpscan.com/vulnerability/495e39db-793d-454b-9ef1-dd91cae2c49b
Get alerted when CVE-2023-0874 or the next vulnerability affects your stack