What’s Vulnerable › Vulnerabilities
CVE-2023-0879: Cross-site Scripting (XSS) - Stored in btcpayserver/btcpayserver
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository btcpayserver/btcpayserver prior to 1.7.12.
Affected products
- btcpayserver/btcpayserver: before 1.7.12 — fixed in 1.7.12
How to fix
Upgrade to a fixed version: btcpayserver/btcpayserver 1.7.12. Check the vendor advisory for mitigations.
References
- https://github.com/btcpayserver/btcpayserver/pull/4635/commits/f2f3b245c4d8980d8e54e4708c796df82332c3d7
- https://huntr.dev/bounties/9464e3c6-961d-4e23-8b3d-07cbb31de541
- https://github.com/btcpayserver/btcpayserver/pull/4635/commits/f2f3b245c4d8980d8e54e4708c796df82332c3d7
- https://huntr.dev/bounties/9464e3c6-961d-4e23-8b3d-07cbb31de541
Get alerted when CVE-2023-0879 or the next vulnerability affects your stack