What’s Vulnerable › Vulnerabilities
CVE-2023-0890: Shortcodes Ultimate < 5.12.8 - Subscriber+ Arbitrary Post Access
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-862
Description
The WordPress Shortcodes Plugin — Shortcodes Ultimate WordPress plugin before 5.12.8 does not ensure that posts to be displayed via some shortcodes are already public and can be accessed by the user making the request, allowing any authenticated users such as subscriber to view draft, private or even password protected posts. It is also possible to leak the password of protected posts
Affected products
- gn_themes WP Shortcodes Plugin — Shortcodes Ultimate: before 5.12.8 — fixed in 5.12.8
How to fix
Upgrade to a fixed version: gn_themes WP Shortcodes Plugin — Shortcodes Ultimate 5.12.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8a466f15-f112-4527-8b02-4544a8032671
- https://wpscan.com/vulnerability/8a466f15-f112-4527-8b02-4544a8032671
Get alerted when CVE-2023-0890 or the next vulnerability affects your stack