What’s Vulnerable › Vulnerabilities
CVE-2023-0891: Stagtools < 2.3.7 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-02 · updated 2026-06-17
- Weakness: CWE-79
Description
The StagTools WordPress plugin before 2.3.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Ram Ratan Maurya, Codestag StagTools: before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: Ram Ratan Maurya, Codestag StagTools 2.3.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/72397fee-9768-462b-933c-400181a5487c
- https://wpscan.com/vulnerability/72397fee-9768-462b-933c-400181a5487c
Get alerted when CVE-2023-0891 or the next vulnerability affects your stack