What’s Vulnerable › Vulnerabilities
CVE-2023-0893: Time Sheets < 1.29.3 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Time Sheets WordPress plugin before 1.29.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Time Sheets: before 1.29.3 — fixed in 1.29.3
How to fix
Upgrade to a fixed version: Time Sheets 1.29.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/fd6ef6ee-15e9-44ac-a2db-976393a3b71a
- https://wpscan.com/vulnerability/fd6ef6ee-15e9-44ac-a2db-976393a3b71a
Get alerted when CVE-2023-0893 or the next vulnerability affects your stack