What’s Vulnerable › Vulnerabilities
CVE-2023-0914: Improper Authorization in pixelfed/pixelfed
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-19 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization in GitHub repository pixelfed/pixelfed prior to 0.11.4.
Affected products
- pixelfed: before 0.11.4 — fixed in 0.11.4
How to fix
Upgrade to a fixed version: pixelfed 0.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/pixelfed/pixelfed/commit/ef56f92c3d77e9bafaa70c08b7c04d5a61b8d454
- https://huntr.dev/bounties/54d5fd76-e038-4eda-9e03-d5e95e09c0ec
- https://github.com/pixelfed/pixelfed/commit/ef56f92c3d77e9bafaa70c08b7c04d5a61b8d454
- https://huntr.dev/bounties/54d5fd76-e038-4eda-9e03-d5e95e09c0ec
Get alerted when CVE-2023-0914 or the next vulnerability affects your stack