What’s Vulnerable › Vulnerabilities
CVE-2023-0926: Custom Permalinks <= 2.6.0 - Authenticated(Editor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Custom Permalinks plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.6.0 due to insufficient input sanitization and output escaping on tag names. This allows authenticated users, with editor-level permissions or greater to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page, even when 'unfiltered_html' has been disabled.
Affected products
- sasiddiqui Custom Permalinks: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: sasiddiqui Custom Permalinks 2.7.0. Check the vendor advisory for mitigations.
References
- https://github.com/samiahmedsiddiqui/custom-permalinks/pull/96
- https://plugins.trac.wordpress.org/changeset/3138206/custom-permalinks/trunk/admin/class-custom-permalinks-post-types-table.php
- https://plugins.trac.wordpress.org/changeset/3138206/custom-permalinks/trunk/admin/class-custom-permalinks-taxonomies-table.php
- https://wordpress.org/plugins/custom-permalinks/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97f8549a-292d-4a6d-8ec0-550467e5cf0f?source=cve
Get alerted when CVE-2023-0926 or the next vulnerability affects your stack