What’s Vulnerable › Vulnerabilities
CVE-2023-0940: ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-863
Description
The ProfileGrid WordPress plugin before 5.3.1 provides an AJAX endpoint for resetting a user password but does not implement proper authorization. This allows a user with low privileges, such as subscriber, to change the password of any account, including Administrator ones.
Affected products
- metagauss ProfileGrid – User Profiles, Groups and Communities: before 5.3.1 — fixed in 5.3.1
How to fix
Upgrade to a fixed version: metagauss ProfileGrid – User Profiles, Groups and Communities 5.3.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/56744f72-2d48-4f42-8195-24b4dd951bb5
- https://wpscan.com/vulnerability/56744f72-2d48-4f42-8195-24b4dd951bb5
Get alerted when CVE-2023-0940 or the next vulnerability affects your stack