What’s Vulnerable › Vulnerabilities
CVE-2023-0950: Array Index UnderFlow in Calc Formula Parsing
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-129
Description
Improper Validation of Array Index vulnerability in the spreadsheet component of The Document Foundation LibreOffice allows an attacker to craft a spreadsheet document that will cause an array index underflow when loaded. In the affected versions of LibreOffice certain malformed spreadsheet formulas, such as AGGREGATE, could be created with less parameters passed to the formula interpreter than it expected, leading to an array index underflow, in which case there is a risk that arbitrary code could be executed. This issue affects: The Document Foundation LibreOffice 7.4 versions prior to 7.4.6; 7.5 versions prior to 7.5.1.
Affected products
- Debian Linux: 10.0
- The Document Foundation LibreOffice: from 7.4.0 before 7.4.6; from 7.5.0 before 7.5.2 — fixed in 7.4.6, 7.5.2
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 7.4.6, 7.5.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/08/msg00014.html
- https://security.gentoo.org/glsa/202311-15
- https://www.debian.org/security/2023/dsa-5415
- https://www.libreoffice.org/about-us/security/advisories/CVE-2023-0950
- https://lists.debian.org/debian-lts-announce/2023/08/msg00014.html
- https://security.gentoo.org/glsa/202311-15
- https://www.debian.org/security/2023/dsa-5415
- https://www.libreoffice.org/about-us/security/advisories/CVE-2023-0950
Get alerted when CVE-2023-0950 or the next vulnerability affects your stack