What’s Vulnerable › Vulnerabilities
CVE-2023-0973: Step Tools Third-Party
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-476
Description
STEPTools v18SP1 ifcmesh library (v18.1) is affected due to a null pointer dereference, which could allow an attacker to deny application usage when reading a specially constructed file, resulting in an application crash.
Affected products
- Step Tools v18SP1 ifcmesh library: before 18.102 — fixed in 18.102
How to fix
Upgrade to a fixed version: Step Tools v18SP1 ifcmesh library 18.102. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/news-events/ics-advisories/icsa-23-068-04
- https://www.cisa.gov/news-events/ics-advisories/icsa-23-068-04
Get alerted when CVE-2023-0973 or the next vulnerability affects your stack