What’s Vulnerable › Vulnerabilities
CVE-2023-1069: Complianz - GDPR/CCPA Cookie Consent < 6.4.2 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
Description
The Complianz WordPress plugin before 6.4.2, Complianz Premium WordPress plugin before 6.4.2 do not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Complianz – GDPR/CCPA Cookie Consent: before 6.4.2 — fixed in 6.4.2
How to fix
Upgrade to a fixed version: Complianz – GDPR/CCPA Cookie Consent 6.4.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/caacc50c-822e-46e9-bc0b-681349fd0dda
- https://wpscan.com/vulnerability/caacc50c-822e-46e9-bc0b-681349fd0dda
Get alerted when CVE-2023-1069 or the next vulnerability affects your stack