What’s Vulnerable › Vulnerabilities
CVE-2023-1089: Coupon Zen < 1.0.6 - Arbitrary Plugin Activation via CSRF
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-27 · updated 2026-06-17
- Weakness: CWE-352
Description
The Coupon Zen WordPress plugin before 1.0.6 does not have CSRF check when activating plugins, which could allow attackers to make logged in admins activate arbitrary plugins present on the blog via a CSRF attack
Affected products
- Coupon Zen: before 1.0.6 — fixed in 1.0.6
How to fix
Upgrade to a fixed version: Coupon Zen 1.0.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9787e26f-33fe-4c65-abb3-7f5c76ae8d6f
- https://wpscan.com/vulnerability/9787e26f-33fe-4c65-abb3-7f5c76ae8d6f
Get alerted when CVE-2023-1089 or the next vulnerability affects your stack