What’s Vulnerable › Vulnerabilities
CVE-2023-1107: Cross-site Scripting (XSS) - Stored in flatpressblog/flatpress
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository flatpressblog/flatpress prior to 1.3.
Affected products
- flatpressblog/flatpress: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/d3f329496536dc99f9707f2f295d571d65a496f5
- https://huntr.dev/bounties/4b880868-bd28-4fd0-af56-7686e55d3762
- https://github.com/flatpressblog/flatpress/commit/d3f329496536dc99f9707f2f295d571d65a496f5
- https://huntr.dev/bounties/4b880868-bd28-4fd0-af56-7686e55d3762
Get alerted when CVE-2023-1107 or the next vulnerability affects your stack