What’s Vulnerable › Vulnerabilities
CVE-2023-1118
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-416
Description
A flaw use after free in the Linux kernel integrated infrared receiver/transceiver driver was found in the way user detaching rc device. A local user could use this flaw to crash the system or potentially escalate their privileges on the system.
Affected products
- Linux kernel: from 2.6.36 before 4.14.308; from 4.15 before 4.19.276; from 4.20 before 5.4.235; from 5.5 before 5.10.173; from 5.11 before 5.15.99; from 5.16 before 6.1.16 — fixed in 4.14.308, 4.19.276, 5.10.173, 5.15.99, 5.4.235, 6.1.16
How to fix
Upgrade to a fixed version: Linux kernel 4.14.308, 4.19.276, 5.10.173, 5.15.99. Check the vendor advisory for mitigations.
References
- https://github.com/torvalds/linux/commit/29b0589a865b6f66d141d79b2dd1373e4e50fe17
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://security.netapp.com/advisory/ntap-20230413-0003/
- https://github.com/torvalds/linux/commit/29b0589a865b6f66d141d79b2dd1373e4e50fe17
- https://lists.debian.org/debian-lts-announce/2023/05/msg00005.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00006.html
- https://security.netapp.com/advisory/ntap-20230413-0003/
Get alerted when CVE-2023-1118 or the next vulnerability affects your stack