What’s Vulnerable › Vulnerabilities
CVE-2023-1146: Cross-site Scripting (XSS) - Generic in flatpressblog/flatpress
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Generic in GitHub repository flatpressblog/flatpress prior to 1.3.
Affected products
- flatpressblog/flatpress: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/0ee4f2e8a7b9276880b56858e408cc9c6643cc3b
- https://huntr.dev/bounties/d6d1e1e2-2f67-4d28-aa84-b30fb1d2e737
- https://github.com/flatpressblog/flatpress/commit/0ee4f2e8a7b9276880b56858e408cc9c6643cc3b
- https://huntr.dev/bounties/d6d1e1e2-2f67-4d28-aa84-b30fb1d2e737
Get alerted when CVE-2023-1146 or the next vulnerability affects your stack