What’s Vulnerable › Vulnerabilities
CVE-2023-1147: Cross-site Scripting (XSS) - Stored in flatpressblog/flatpress
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-02 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository flatpressblog/flatpress prior to 1.3.
Affected products
- flatpressblog/flatpress: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: flatpressblog/flatpress 1.3. Check the vendor advisory for mitigations.
References
- https://github.com/flatpressblog/flatpress/commit/264217f318a8852c4f3e34350d4a0e1363cdd727
- https://huntr.dev/bounties/187f5353-f866-4d26-a5ba-fca378520020
- https://github.com/flatpressblog/flatpress/commit/264217f318a8852c4f3e34350d4a0e1363cdd727
- https://huntr.dev/bounties/187f5353-f866-4d26-a5ba-fca378520020
Get alerted when CVE-2023-1147 or the next vulnerability affects your stack