What’s Vulnerable › Vulnerabilities
CVE-2023-1161
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-06 · updated 2026-06-17
- Weakness: CWE-120
Description
ISO 15765 and ISO 10681 dissector crash in Wireshark 4.0.0 to 4.0.3 and 3.6.0 to 3.6.11 allows denial of service via packet injection or crafted capture file
Affected products
- Debian Linux: 10.0, 12.0
- Wireshark Foundation Wireshark: from 3.6.0 before 3.6.12; from 4.0.0 before 4.0.4 — fixed in 3.6.12, 4.0.4
How to fix
Upgrade to a fixed version: Wireshark Foundation Wireshark 3.6.12, 4.0.4. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1161.json
- https://gitlab.com/wireshark/wireshark/-/issues/18839
- https://lists.debian.org/debian-lts-announce/2023/04/msg00029.html
- https://security.gentoo.org/glsa/202309-02
- https://www.debian.org/security/2023/dsa-5429
- https://www.wireshark.org/security/wnpa-sec-2023-08.html
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1161.json
- https://gitlab.com/wireshark/wireshark/-/issues/18839
- https://lists.debian.org/debian-lts-announce/2023/04/msg00029.html
- https://lists.debian.org/debian-lts-announce/2024/09/msg00049.html
- https://security.gentoo.org/glsa/202309-02
- https://www.debian.org/security/2023/dsa-5429
Get alerted when CVE-2023-1161 or the next vulnerability affects your stack