What’s Vulnerable › Vulnerabilities
CVE-2023-1164: KylinSoft kylin-activation File Import improper authorization
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-03 · updated 2026-06-17
- Weakness: CWE-285
Description
A vulnerability was found in KylinSoft kylin-activation on KylinOS and classified as critical. Affected by this issue is some unknown functionality of the component File Import. The manipulation leads to improper authorization. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.11-23 and 1.30.10-5.p23 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-222260.
Affected products
- KylinSoft kylin-activation: before 1.3.11-23; before 1.30.10-5.p23 — fixed in 1.3.11-23, 1.30.10-5.p23
How to fix
Upgrade to a fixed version: KylinSoft kylin-activation 1.3.11-23, 1.30.10-5.p23. Check the vendor advisory for mitigations.
References
- https://github.com/i900008/vulndb/blob/main/kylin-activation_vuln.md
- https://vuldb.com/?ctiid.222260
- https://vuldb.com/?id.222260
- https://github.com/i900008/vulndb/blob/main/kylin-activation_vuln.md
- https://vuldb.com/?ctiid.222260
- https://vuldb.com/?id.222260
Get alerted when CVE-2023-1164 or the next vulnerability affects your stack