What’s Vulnerable › Vulnerabilities
CVE-2023-1170: Heap-based Buffer Overflow in vim/vim
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-03 · updated 2026-09-18
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.1376.
Affected products
- Fedoraproject Fedora: 36, 37, 38
- Neovim: through 0.8.3
- vim/vim: before 9.0.1376 — fixed in 9.0.1376
How to fix
Upgrade to a fixed version: vim/vim 9.0.1376. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/1c73b65229c25e3c1fd8824ba958f7cc4d604f9c
- https://huntr.dev/bounties/286e0090-e654-46d2-ac60-29f81799d0a4
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DIAKPMKJ4OZ6NYRZJO7YWMNQL2BICLYV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IE44W6WMMREYCW3GJHPSYP7NK2VT5NY6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X4KDAU76Z7QNSPKZX2JAJ6O7KIEOXWTL/
- https://github.com/vim/vim/commit/1c73b65229c25e3c1fd8824ba958f7cc4d604f9c
- https://huntr.dev/bounties/286e0090-e654-46d2-ac60-29f81799d0a4
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DIAKPMKJ4OZ6NYRZJO7YWMNQL2BICLYV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IE44W6WMMREYCW3GJHPSYP7NK2VT5NY6/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X4KDAU76Z7QNSPKZX2JAJ6O7KIEOXWTL/
Get alerted when CVE-2023-1170 or the next vulnerability affects your stack