What’s Vulnerable › Vulnerabilities

CVE-2023-1178

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.6 before 15.9.6, all versions starting from 15.10 before 15.10.5, all versions starting from 15.11 before 15.11.1. File integrity may be compromised when source code or installation packages are pulled from a tag or from a release containing a ref to another commit.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.10.5, 15.11.1, 15.9.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-1178 or the next vulnerability affects your stack