What’s Vulnerable › Vulnerabilities
CVE-2023-1196: Advanced Custom Fields - Contributor+ PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-02 · updated 2026-06-17
- Weakness: CWE-502
Description
The Advanced Custom Fields (ACF) Free and Pro WordPress plugins 6.x before 6.1.0 and 5.x before 5.12.5 unserialize user controllable data, which could allow users with a role of Contributor and above to perform PHP Object Injection when a suitable gadget is present.
Affected products
- WP Engine Advanced Custom Fields: from 5.0.0 before 5.12.5; from 6.0.0 before 6.1.0 — fixed in 5.12.5, 6.1.0
How to fix
Upgrade to a fixed version: WP Engine Advanced Custom Fields 5.12.5, 6.1.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8e5ec88e-0e66-44e4-bbf2-74155d849ede
- https://wpscan.com/vulnerability/cf376ca2-92f6-44ff-929a-ace809460a33
- https://wpscan.com/vulnerability/8e5ec88e-0e66-44e4-bbf2-74155d849ede
- https://wpscan.com/vulnerability/cf376ca2-92f6-44ff-929a-ace809460a33
Get alerted when CVE-2023-1196 or the next vulnerability affects your stack