What’s Vulnerable › Vulnerabilities
CVE-2023-1204
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-03 · updated 2026-06-17
- Weakness: CWE-347
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.1 before 15.10.8, all versions starting from 15.11 before 15.11.7, all versions starting from 16.0 before 16.0.2. A user could use an unverified email as a public email and commit email by sending a specifically crafted request on user update settings.
Affected products
- GitLab: from 10.0 before 12.9.8; from 12.10 before 12.10.7; from 13.0 before 13.0.1 — fixed in 12.10.7, 12.9.8, 13.0.1
How to fix
Upgrade to a fixed version: GitLab 12.10.7, 12.9.8, 13.0.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1204.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/394745
- https://hackerone.com/reports/1881598
- https://gitlab.com/gitlab-org/cves/-/blob/master/2023/CVE-2023-1204.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/394745
- https://hackerone.com/reports/1881598
- https://gitlab.com/gitlab-org/gitlab/-/issues/394745
Get alerted when CVE-2023-1204 or the next vulnerability affects your stack