What’s Vulnerable › Vulnerabilities
CVE-2023-1252
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-416
Description
A use-after-free flaw was found in the Linux kernel’s Ext4 File System in how a user triggers several file operations simultaneously with the overlay FS usage. This flaw allows a local user to crash or potentially escalate their privileges on the system. Only if patch 9a2544037600 ("ovl: fix use after free in struct ovl_aio_req") not applied yet, the kernel could be affected.
Affected products
- Linux kernel: from 5.6 before 5.10.80; from 5.11 before 5.14.19; from 5.15 before 5.15.3 — fixed in 5.10.80, 5.14.19, 5.15.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.80, 5.14.19, 5.15.3. Check the vendor advisory for mitigations.
References
- https://lore.kernel.org/lkml/20211115165433.449951285%40linuxfoundation.org/
- https://security.netapp.com/advisory/ntap-20230505-0005/
- https://lore.kernel.org/lkml/20211115165433.449951285%40linuxfoundation.org/
- https://security.netapp.com/advisory/ntap-20230505-0005/
Get alerted when CVE-2023-1252 or the next vulnerability affects your stack