What’s Vulnerable › Vulnerabilities
CVE-2023-1269: Use of Hard-coded Credentials in alextselegidis/easyappointments
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-798
Description
Use of Hard-coded Credentials in GitHub repository alextselegidis/easyappointments prior to 1.5.0.
Affected products
- alextselegidis/easyappointments: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: alextselegidis/easyappointments 1.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/alextselegidis/easyappointments/commit/2731d2f17c5140c562426b857e9f5d63da5c4593
- https://huntr.dev/bounties/91c31eb6-024d-4ad3-88fe-f15b03fd20f5
- https://github.com/alextselegidis/easyappointments/commit/2731d2f17c5140c562426b857e9f5d63da5c4593
- https://huntr.dev/bounties/91c31eb6-024d-4ad3-88fe-f15b03fd20f5
Get alerted when CVE-2023-1269 or the next vulnerability affects your stack