What’s Vulnerable › Vulnerabilities
CVE-2023-1270: Cross-site Scripting in btcpayserver/btcpayserver
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-08 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting in GitHub repository btcpayserver/btcpayserver prior to 1.8.3.
Affected products
- Btcpayserver: before 1.8.3 — fixed in 1.8.3
How to fix
Upgrade to a fixed version: Btcpayserver 1.8.3. Check the vendor advisory for mitigations.
References
- https://github.com/btcpayserver/btcpayserver/commit/7b5ce8f70c060b01990d3f7109e97e0144d878a4
- https://huntr.dev/bounties/ad1f917f-2b25-40ef-9215-c805354c683b
- https://github.com/btcpayserver/btcpayserver/commit/7b5ce8f70c060b01990d3f7109e97e0144d878a4
- https://huntr.dev/bounties/ad1f917f-2b25-40ef-9215-c805354c683b
Get alerted when CVE-2023-1270 or the next vulnerability affects your stack