What’s Vulnerable › Vulnerabilities
CVE-2023-1389: TP-Link Archer AX-21 Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2023-05-01
- EPSS: 100.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-15 · updated 2026-06-17
- Weakness: CWE-77
Description
TP-Link Archer AX21 (AX1800) firmware versions before 1.1.4 Build 20230219 contained a command injection vulnerability in the country form of the /cgi-bin/luci;stok=/locale endpoint on the web management interface. Specifically, the country parameter of the write operation was not sanitized before being used in a call to popen(), allowing an unauthenticated attacker to inject commands, which would be run as root, with a simple POST request.
Affected products
- TP-Link Archer AX21: before 1.1.4 — fixed in 1.1.4
How to fix
Upgrade to a fixed version: TP-Link Archer AX21 1.1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/174131/TP-Link-Archer-AX21-Command-Injection.html
- https://www.tenable.com/security/research/tra-2023-11
- http://packetstormsecurity.com/files/174131/TP-Link-Archer-AX21-Command-Injection.html
- https://www.tenable.com/security/research/tra-2023-11
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-1389
Get alerted when CVE-2023-1389 or the next vulnerability affects your stack