What’s Vulnerable › Vulnerabilities
CVE-2023-1402: Moodle: course participation report shows roles the user should not see
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-200
Description
The course participation report required additional checks to prevent roles being displayed which the user did not have access to view.
Affected products
- Moodle: from 3.9.0 (excl.) before 3.9.20; from 3.11.0 (excl.) before 3.11.13; from 4.0.0 (excl.) before 4.0.7; 3.9.0, 3.11.0, 4.0.0, 4.1.0, 4.1.1 — fixed in 3.11.13, 3.9.20, 4.0.7
How to fix
Upgrade to a fixed version: Moodle 3.11.13, 3.9.20, 4.0.7. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2179427
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF/
- https://moodle.org/mod/forum/discuss.php?d=445069
- https://bugzilla.redhat.com/show_bug.cgi?id=2179427
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QZN34VSF4HTCW3C3ZP2OZYSLYUKADPF/
- https://moodle.org/mod/forum/discuss.php?d=445069
Get alerted when CVE-2023-1402 or the next vulnerability affects your stack