What’s Vulnerable › Vulnerabilities
CVE-2023-1409: Certificate validation issue in MongoDB Server running on Windows or macOS
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-23 · updated 2026-06-17
- Weakness: CWE-295
Description
If the MongoDB Server running on Windows or macOS is configured to use TLS with a specific set of configuration options that are already known to work securely in other platforms (e.g. Linux), it is possible that client certificate validation may not be in effect, potentially allowing client to establish a TLS connection with the server that supplies any certificate. This issue affect all MongoDB Server v6.3 versions, MongoDB Server v5.0 versions v5.0.0 to v5.0.14 and all MongoDB Server v4.4 versions.
Affected products
- MongoDB: from 4.4.0 before 4.4.23; from 5.0.0 through 5.0.14; from 6.0.0 before 6.0.7; from 6.3.0 through 6.3.2 — fixed in 4.4.23, 6.0.7
How to fix
Upgrade to a fixed version: MongoDB 4.4.23, 6.0.7. Check the vendor advisory for mitigations.
References
- https://jira.mongodb.org/browse/SERVER-73662
- https://jira.mongodb.org/browse/SERVER-77028
- https://security.netapp.com/advisory/ntap-20230921-0007/
- https://jira.mongodb.org/browse/SERVER-73662
- https://jira.mongodb.org/browse/SERVER-77028
- https://security.netapp.com/advisory/ntap-20230921-0007/
Get alerted when CVE-2023-1409 or the next vulnerability affects your stack