What’s Vulnerable › Vulnerabilities
CVE-2023-1428: Denial-of-Service in gRPC
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-09 · updated 2026-06-17
- Weakness: CWE-617
Description
There exists an vulnerability causing an abort() to be called in gRPC. The following headers cause gRPC's C++ implementation to abort() when called via http2: te: x (x != trailers) :scheme: x (x != http, https) grpclb_client_stats: x (x == anything) On top of sending one of those headers, a later header must be sent that gets the total header size past 8KB. We recommend upgrading past git commit 2485fa94bd8a723e5c977d55a3ce10b301b437f8 or v1.53 and above.
Affected products
- Google gRPC: from 1.51.0 before 1.53.0 — fixed in 1.53.0
How to fix
Upgrade to a fixed version: Google gRPC 1.53.0. Check the vendor advisory for mitigations.
References
- https://github.com/grpc/grpc/commit/2485fa94bd8a723e5c977d55a3ce10b301b437f8
- https://github.com/grpc/grpc/commit/2485fa94bd8a723e5c977d55a3ce10b301b437f8
Get alerted when CVE-2023-1428 or the next vulnerability affects your stack