What’s Vulnerable › Vulnerabilities
CVE-2023-1496: Cross-site Scripting (XSS) - Reflected in imgproxy/imgproxy
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository imgproxy/imgproxy prior to 3.14.0.
Affected products
- imgproxy/imgproxy: before 3.14.0 — fixed in 3.14.0
How to fix
Upgrade to a fixed version: imgproxy/imgproxy 3.14.0. Check the vendor advisory for mitigations.
References
- https://github.com/imgproxy/imgproxy/commit/62f8d08a93d301285dcd1dabcc7ba10c6c65b689
- https://huntr.dev/bounties/de603972-935a-401a-96fb-17ddadd282b2
- https://github.com/imgproxy/imgproxy/commit/62f8d08a93d301285dcd1dabcc7ba10c6c65b689
- https://huntr.dev/bounties/de603972-935a-401a-96fb-17ddadd282b2
Get alerted when CVE-2023-1496 or the next vulnerability affects your stack