What’s Vulnerable › Vulnerabilities
CVE-2023-1521: Local Privilege Escalation in sccache
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-426
Description
On Linux the sccache client can execute arbitrary code with the privileges of a local sccache server, by preloading the code in a shared library passed to LD_PRELOAD. If the server is run as root (which is the default when installing the snap package https://snapcraft.io/sccache ), this means a user running the sccache client can get root privileges.
Affected products
- Mozilla sccache: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: Mozilla sccache 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/advisories/GHSA-x7fr-pg8f-93f5
- https://securitylab.github.com/advisories/GHSL-2023-046_ScCache
Get alerted when CVE-2023-1521 or the next vulnerability affects your stack