What’s Vulnerable › Vulnerabilities
CVE-2023-1523
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-01 · updated 2026-06-17
- Weakness: CWE-74
Description
Using the TIOCLINUX ioctl request, a malicious snap could inject contents into the input of the controlling terminal which could allow it to cause arbitrary commands to be executed outside of the snap sandbox after the snap exits. Graphical terminal emulators like xterm, gnome-terminal and others are not affected - this can only be exploited when snaps are run on a virtual console.
Affected products
- Canonical Ltd. snapd: before 2.59.5 — fixed in 2.59.5
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04, 22.04, 22.10, 23.04
How to fix
Upgrade to a fixed version: Canonical Ltd. snapd 2.59.5. Check the vendor advisory for mitigations.
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-1523
- https://github.com/snapcore/snapd/pull/12849
- https://marc.info/?l=oss-security&m=167879021709955&w=2
- https://ubuntu.com/security/notices/USN-6125-1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-1523
- https://github.com/snapcore/snapd/pull/12849
- https://marc.info/?l=oss-security&m=167879021709955&w=2
- https://ubuntu.com/security/notices/USN-6125-1
Get alerted when CVE-2023-1523 or the next vulnerability affects your stack