What’s Vulnerable › Vulnerabilities
CVE-2023-1550: NGINX Agent vulnerability CVE-2023-1550
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-532
Description
Insertion of Sensitive Information into log file vulnerability in NGINX Agent. NGINX Agent version 2.0 before 2.23.3 inserts sensitive information into a log file. An authenticated attacker with local access to read agent log files may gain access to private keys. This issue is only exposed when the non-default trace level logging is enabled. Note: NGINX Agent is included with NGINX Instance Manager and used in conjunction with NGINX API Connectivity Manager, and NGINX Management Suite Security Monitoring.
Affected products
- F5 NGINX Agent: from 2.0.0 before 2.23.3 — fixed in 2.23.3
- F5 NGINX Instance Manager: from 2.0.0 before 2.9.0 — fixed in 2.9.0
How to fix
Upgrade to a fixed version: F5 NGINX Agent 2.23.3; F5 NGINX Instance Manager 2.9.0. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000133135
- https://security.netapp.com/advisory/ntap-20230511-0008/
- https://my.f5.com/manage/s/article/K000133135
- https://security.netapp.com/advisory/ntap-20230511-0008/
Get alerted when CVE-2023-1550 or the next vulnerability affects your stack