What’s Vulnerable › Vulnerabilities
CVE-2023-1572: DataGear Plugin cross site scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-22 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability has been found in DataGear up to 1.11.1 and classified as problematic. This vulnerability affects unknown code of the component Plugin Handler. The manipulation leads to cross site scripting. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.12.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-223564.
Affected products
- DataGear: before 1.12.0 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: DataGear 1.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/datageartech/datagear/releases/tag/v1.12.0
- https://github.com/yangyanglo/ForCVE/blob/main/2023-0x03.md
- https://github.com/yangyanglo/ForCVE/edit/main/2023-0x03.md
- https://vuldb.com/?ctiid.223564
- https://vuldb.com/?id.223564
- https://github.com/datageartech/datagear/releases/tag/v1.12.0
- https://github.com/yangyanglo/ForCVE/blob/main/2023-0x03.md
- https://github.com/yangyanglo/ForCVE/edit/main/2023-0x03.md
- https://vuldb.com/?ctiid.223564
- https://vuldb.com/?id.223564
Get alerted when CVE-2023-1572 or the next vulnerability affects your stack