What’s Vulnerable › Vulnerabilities
CVE-2023-1624: WPCode Lite < 2.0.9 - Arbitrary Log File Deletion via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-04-24 · updated 2026-06-17
Description
The WPCode WordPress plugin before 2.0.9 has a flawed CSRF when deleting log, and does not ensure that the file to be deleted is inside the expected folder. This could allow attackers to make users with the wpcode_activate_snippets capability delete arbitrary log files on the server, including outside of the blog folders
Affected products
- WPCode: before 2.0.9 — fixed in 2.0.9
How to fix
Upgrade to a fixed version: WPCode 2.0.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/132b70e5-4368-43b4-81f6-2d01bc09dc8f
- https://wpscan.com/vulnerability/132b70e5-4368-43b4-81f6-2d01bc09dc8f
Get alerted when CVE-2023-1624 or the next vulnerability affects your stack