What’s Vulnerable › Vulnerabilities
CVE-2023-1651: ChatBot < 4.4.9 - Subscriber+ OpenAI Settings Update to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-05-08 · updated 2026-06-17
Description
The AI ChatBot WordPress plugin before 4.4.9 does not have authorisation and CSRF in the AJAX action responsible to update the OpenAI settings, allowing any authenticated users, such as subscriber to update them. Furthermore, due to the lack of escaping of the settings, this could also lead to Stored XSS
Affected products
- quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services: before 4.4.9 — fixed in 4.4.9
How to fix
Upgrade to a fixed version: quantumcloud WPBot – AI ChatBot for Live Support, Lead Generation, AI Services 4.4.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c88b22ba-4fc2-49ad-a457-224157521bad
- https://wpscan.com/vulnerability/c88b22ba-4fc2-49ad-a457-224157521bad
Get alerted when CVE-2023-1651 or the next vulnerability affects your stack